Can't find Bench folder on my server

i will like to use this moment to thank all developer of erpnext, kudos to you guys well done job.
please i’m new to this system, and also not too good in using linux, but i try to install the the system, currently running on production mode with ubuntu linux, i want to switch to developer mode but can’t find the bench folder.

please help.

First, welcome to the community.

From home it should work something like this:
ls ← do this at each step to show the contents of the directory you’re in
"frappe" "akajiaku" ← these are directories in home, “frappe” and the “other user(s) on the system”
cd frappe ← change directory to the user frappe, which is automatically created in a production install
cd frappe-bench ← unless you’ve named your bench something during a manual install (if you entered the bench init <name> command, otherwise it’s named frappe-bench)
cd sites
ls ← shows the site(s) you have installed in this instance
cd my-new-site ← the site you created when you entered the the bench new-site my-new-site command
sudo nano site_config.json ← opens the site config which will look like this:

 "db_name": "whole1lotta2hash", 
 "db_password": "garbled3mess", 
 "developer_mode": 1, 
 "encryption_key": "something4long5and6crazy7looking=!", 
 "limits": {
  "space_usage": {
   "backup_size": 3.0, 
   "database_size": 38.83, 
   "files_size": 2.0, 
   "total": 43.83

This site_config.json is from a docker install, you shouldn’t need to change the values below developer_mode until you’re more familiar with bench setups (like doing them manually because you’re build some kind of unique installation; and you may never have to change them in your frappe career).

If this doesn’t work for you, you should find a tutorial on linux command line stuff (I like the codeacademy one, but it’s long) because you’ll keep using it and you’ll learn something that will help you find the source of your installation troubles but it’s not going to be a quick fix, it’s a long term skill. Lots of excellent chefs are also excellent dish washers just because they’ve spent a lot of time in the kitchen, not because they went to culinary school and learned expert dish washing. This is a little bit like that.

I am not a talented chef but I make a decent turkey sandwich.

1 Like

thank you soo much, i really appreciate your support, i will give it a trial tomorrow, you really explain it well like a teacher.

thanks, i will still get back to you if needs arise.

I am happy to help. Please consider giving back to the community by posting the solution to your problem, because I’m certain that someone else has had it.

Hey @Akajiaku_Nwabekee, did you get this figured out?

yes man

1 Like

Nice! If you mark it as a solution, it will automatically close this issue.

please im trying to setup the ssl certificate, but at the process i got error, and since then the site has been under maintenance mode, i restart the bench, both nginx still under maintenace mode. what do i do?

Have you worked through this guide? Specifically: sudo bench setup lets-encrypt [site-name]

Also, you probably need to post the trace of the error you’re getting so that we can help with that. I get lotsa errors. We all get lotsa errors.

Yes I did, I got error while installing . failed to install the SSL and since then my site stop working. I used, it showed success but don’t reflect on the web browser, so I decided to get a full domain for this purpose which is, though I used the same email with
Please help.

Worst case, start over. It sounds like you need to run this set of commands to configure your server:

bench setup procfile
bench setup nginx
bench setup supervisor
bench setup redis
bench restart

When in doubt, try bench restart

i finally get my ssl certificate installed, but after that my site refused to load with https. what can i do?

What error are you getting? From the console rather than the page.

No error, the SSL installed well, and since then I can’t access the site anymore, because it now redirect to https when trying to access the web page. Though I use a subdomain on this, I don’t know what next to do

@Tmatteson , thanks for your support so far, I do appreciate.

Well this is hard to debug because you can’t see any console errors. Can you tell us what you tried?
bench restart ?