Can't install custom app in v13.26

I have a custom app which was created on v13.0.1 and it installs find everytime

I have simply copied the custom app folder and pasted in the apps folder

However when I tried to install it on the v13.26.0; it gives me this error:

What are we doing wrong?

@SamSam did you installed this app from github ? are you sure it’s a valid app ?

it’s a custom app I made for custom theming.

It’s working on 13.0.1; so yeah I would say it’s valid. Any idea what’s the above error means?

Get sure to run your script in frappe-bench folder.

You can see I am running it there in the screenshot.

you are running this inside sites folder not frappe-bench!!
cd …
then run your script

Same error, I used to install them in sites folder too; it didn’t make much difference.

Here I am even sharing the app (without the .git obviously), it’s just for custom css basically.

This same app I am able to install it on erpnext that is running in my oracle vm, v13.0.1; while the production is running 13.26.

Apparently it was because i had those uncommented in the

# before_install = "motakamila_theme.install.before_install"
# after_install = "motakamila_theme.install.after_install"