Can't submit my BOM because `Must be Whole Number` while I have chosen `Kg` UoM


I don’t understand when I submit my BOM imported, I have :

No. Item | Item code | Qty | UoM
1 | Packaging | 1 | Unit
2 | Oil | 0,05 | Kg

I have an error:
Row 2: Quantity (0.05) cannot be a fraction. To allow this, disable '**Must be Whole Number**' in UOM **Unit**.

I don’t understand why it mentions Unit, I have chosen Kg and Kg can be a fraction number.

My stack : I’m on Frappe Cloud v14

Hi @Raph01,

Please go to UOM and check it in Unit UOM.
If enable Must be Whole Number then disable it.
Then reload (Ctrl + Shift + R) and check it.

Thank You!

1 Like

Thank you NCP, but now for the next time when I will put a decimal for Unit (what I don’t want), it will works but I would like to have an alert at this moment.
It’s why I don’t understand my error.