Change UOM in the print format from Stock UOM to Selling UOM


I tried changing UOM from stock to selling UOM, but it is not reflected here in the print format.

Default sales UOM

And, here’s the settings for print format builder

1 Like

If you customize the SO print format, do you have these columns?

Yes - but don’t think one can change Quantity UOM from the UI, I think custom html is required.

I have a similar problem in Quotation with stock UOM
ERPNext: v11.1.65
Frappe Framework: v11.1.59

Tried customizing Sales Order Item form and adding Sales UOM as link to sales_uom.
Then in a custom print format that uses it. Haven’t tested it, however though it could be something to try. I need an example of a use case.

Keep in mind when setting up the Item, there are Default UOM and also a Default Sales UOM in Sales Details, as well as the Units of measure section itself. Not sure where Stock UOM is set.

Stock UOM is the Default UOM.

Did anyone find a solution or Work around for this?

Did anyone find a fix for this? Trying to show the sales UOM without showing the qty for quotes where we are quoting rates only.