Changes made in frappe app is not working

I made some changes in frappe app. frappe/public/js/frappe/ui/upload.html changes are working fine in local system.but it is not working in aws.(changes are made in erpnext and custom app are working fine in aws)

i tried bench restart
server restart

but the changes are not reflecting .please help

Did you try to reload the changes from the browser?

Yes.i did

How are you making changes for the hosted instance? SSH, FTP?

using ssh.

i will make changes in local system and commit and push to git.changes are working fine in local system.

after login into cloud system using ssh,i will pull changes.i tried bench restart,cloud server reboot,page refresh after pull the code

but it is not effecting,only issue for frappe app


####On git pull were your changes pulled on the AWS server?

  • If Yes, then you may have to run bench build to build combined assets for ERPNext.
  • If No, you are changes are not getting fetched to AWS server, then please check the remote branch and try fetching your changes and then running bench build.

Note: As a best practice, please run bench update on the production server as it will take care to pull the changes to your application, migrate your site, restart the bench as well as build combined assets for the bench.

1 Like

Thank you.It worked after running bench build command