Chat not refreshing

I just installed vanilla frappe, the chat sends message but i have to refresh for it to show. even creation of chat room has to be refreshed to show.
No error enither on the JS log or server logs.

1 Like

I have the same issue.

I am also getting the same issue. Is that something to do with Nginx???

I use erpnext with apache(bitnami stack) and also having this issue. Chat is not refreshing.
Apache log :
[proxy:error] … (111)Connection refused: AH00957: HTTP: attempt to connect to (localhost) failed
[proxy_http:error] … [client] AH01114: HTTP: failed to make connection to backend: localhost, …
ERPNext: v12.5.2 (version-12)
Frappe Framework: v12.3.0 (version-12)
I am no expert, just currious: is the = socket io server which is not running ? (how to check if its running or not) so the clients / chat can not refresh. ?


I have the same issue. I did not see any error in javascript.

I am getting same issue. Please help me.


I also have same issue on development setup but when I use easy install for producrion on ubuntu 18.04. Its working fine.
Have no clue for the reason.

Your socket IO is not working correctly in development.
Please follow this tutorial:

Please check your socket io logs for the possible connectivity issues. If its production environment the logs are available in the bench folder at logs/node-socketio.log

Hi Mohammad_Ahmad_Zulfi,

Thanks for your reply, I will post back as soon as I have try your suggestion.

Thanks again

The sample works perfectly but still I cant resolve the problem on erpnext dev environment so I currently studying more about the socket io.
1 question . the erpnext socket io is running on port 9000 right? not 3000 (default).
I come to this conclusion cause I can do a tutorial on socket io which use the port 3000 succesfully in the active/ running erpnext server.
Sorry for my newbie question

Ok, i think i have to stop my post until I learn enough about the socketio and know what i am doing …

Have tried the tutorial for dev environment I shared above? What have tried yet in the dev environment

Ok, its working on production and development now.
Is it because of the tutorial or the version I am using now. ?
cause I did not see any modification on the settings except setting mulitenant off, remove the currentsite.txt and adding /etc/hosts with the site name.

I use the latest erpnext v12.10 on master

Thanks for your help.