Chosing a different UOM than the default one for an item in Sales Quotation is not displayed

What I did on ERPNEXT V12.0.5

  1. I created a new sales quotation
  2. I added items to the quotation
  3. For one item, which has “Hour” as UOM, I chose “Man-Day” as UOM (man-day is a self created UOM)
  4. I saved the quotation
  5. I clicked on the “printer” button to preview the quotation
  6. Result: In the items list, there where hours displayed instead of man-days. (Refreshing page did not help)

As a workaround I changed the default UOM of the item to “Man-day”. But always changing the default is maybe not the best way to solve that problem.

So I would be happy if anyone has ideas how to solve that, or if someone can reproduce it and confirm, that it is a bug in V12.

This is a known issue since version 11 or earlier on Quotations, Sales Orders and Sales Invoices. Purchase orders are OK. If you go to print format for any of the ones with problems, for example Quotation:

  • click on Edit Format you see the items are in the Item (table) part and there is a button for select columns
  • notice that what is checked and has a width value is Stock UOM not UOM, explaining why what is printed is always the stock UOM not the UOM chosen for that transaction

What is weird is that even after having unchecked Stock UOM, checked UOM and given it a width what shows up on actual print is still stock UOM. Looked at Purchase order format (which works) items column and set Sales Order items columns, order, width identical, but still no luck. ERPNext is ignoring entries in select columns for child tables on selling print formats. Have not been able to figure out why.