Clear expired sessions error

Dears im getting this error any ideas how to resolve it. i renamed my user and now i get this error
{‘retry’: 0, ‘log’: <function log at 0x7f5cb8ddb230>, ‘site’: u’site1.local’, ‘event’: u’daily’, ‘method_name’: u’frappe.sessions.clear_expired_sessions’, ‘method’: <function clear_expired_sessions at 0x7f5cb8f07230>, ‘user’: u’Administrator’, ‘kwargs’: {}, ‘async’: True, ‘job_name’: u’frappe.sessions.clear_expired_sessions’}
Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 97, in execute_job
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 136, in clear_expired_sessions
delete_session(sid, reason=“Session Expired”)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 112, in delete_session
logout_feed(user, reason)
File “/home/frappe/frappe-bench/apps/frappe/frappe/core/doctype/activity_log/”, line 57, in logout_feed
add_authentication_log(subject, user, operation=“Logout”)
File “/home/frappe/frappe-bench/apps/frappe/frappe/core/doctype/activity_log/”, line 44, in add_authentication_log
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 217, in insert
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 724, in _validate_links
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 323, in throw
msgprint(msg, raise_exception=exc, title=title, indicator=‘red’)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 309, in msgprint
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 282, in _raise_exception
raise raise_exception(encode(msg))
LinkValidationError: Could not find User: sul

try to login with the email ID mentioned after renaming.

i tried now i will update you in few days if we get the error again thanks a lot

hello umair
FYI im still getting the same error

did you manage to solve this?
I am getting exact error.
Please help

I have the same error too but only for one of my users

hello everyone asking the same question and i apologize for not updating this faster. i have done 2 things and im not sure which one solved it:
1- logged in as admin deleted the user and created a new one
2- updated the system

1 Like