Command not found: bench

I installed the pre-requisite for installing Frappe Framework on the macBook through Homebrew. I cloned Frappe bench but I can not pip this “pip install --user -e bench-repo” from this guideline (Installation). This is my first exposure to this!
here is what I have on my terminal: Do you think this seems odd!
I even reinstalled python but still does not work!


Could anyone kindly help me out! Thank you in advance!

@Ismail_Ahmadi try this sudo pip install -e bench-repo

sudo -H python3 -m pip install frappe-bench should install bench at root level and your system users will be able to use it then.

Also, editable installs are not encouraged for production usage.

1 Like

Thank you for your help, I tried and the outcome is
sudo: pip: command not found
so this does not work! :expressionless:

Thank you so much! it worked, but I got a warning about it when I run “bench --version”.
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: `pip install frappe-bench`

WARN: Command not being executed in bench directory

any suggestion for this problem?

This command line still does not work!!

pip install frappe-bench

can you run bench --version to check if the previous bench has been uninstalled correctly and the entry point is linked to the newly installed version?

if it says 4.1.0 or any other < 5.0.0 then, try deleting the bench-repo or .bench folder in your home directory (or where ever you had it cloned) and remove the corresponding egg-link file from under your Python site-packages.

Perhaps, also remove the bench entry point file by running rm $(which bench) and finally pip install --no-cache-dir --force-reinstall frappe-bench

1 Like

Thank you so much for getting back to me again! I am very new to this ERPNext and I have less knowledge about how this works! I am using macBook which it comes with Python and python2 and for running python3, I need to have a virtual environment and run this code " pip install -e bench-repo". Thanks again for helping me out @gavindsouza! Have a safe and blessed day!

if my version is 5.1.0 and I still face this issue what should I do?

@Rakesh_dev this isn’t a bench issue; it’s likely a pip one. It’s not setting your packages in PATH. I’d suggest installing bench for root user alone if you’re using pip install frappe-bench instead of the editable install. or look further into the PATH issue. Maybe refer to this SO post.

this helped, thanks!!

➜  pip show frappe-bench
Name: frappe-bench
Version: 5.22.6
Summary: CLI to manage Multi-tenant deployments for Frappe apps
Home-page: https://frappe.io/bench
Author: 
Author-email: Frappe Technologies Pvt Ltd <developers@frappe.io>
License: 
Location: /Library/Frameworks/Python.framework/Versions/3.11/lib/python3.11/site-packages
Requires: click, gitpython, honcho, jinja2, python-crontab, requests, semantic-version, setuptools
Required-by: 

➜ which bench
bench not found

➜  whereis bench
bench:

➜ where bench
bench not found

Followed Frappe documentation, but still the same issue. Also tried to add global still the same issue. Any help appreciated?