Company None not found error


I created a new company, created a new employee and user and set user permissions to the new company.

I am getting this error from the new user’s account.


Any one knows why is this error occurring and how to solve it ?

Hi @anupd,

I think, Please default company set in Global Defaults.
Then reload and check it.


Tried that.

The error only produces in the new user who is set for new company.

There are many users in total for Old Company. Global Defaults has Old company set as default company.

I now created a New Company and a New User. When I login with New User, only then this error is produced.

Similar error is produced in Buying module and some others as well.

The problem is:

  • If I set in Global defaults: default company = Old Company, the new user (with access to new company only via user permissions) gets those error
  • If I set in Global defaults: default company = New Company, the old users (with access to old company only via user permissions) gets those error.

Hi @anupd,

For that case, Is default set in User Permission.


NO, Is Default is NOT set for any users.

So set for user and check it, please.

Did this, for new user.
User: New user
Allow: Company
For value: New Company
Is default: Yes

Still the same error persists.

Which version do you use?

Its v13


Bringing in @peterg @flexy2ky
Could you please suggest something ?

Is it a bug or was is designed like this and I could not find the correct way to deal with it ?

Is it just the dashboards giving the error? Is your new employee able to see/use the new company document in other settings?

Until now, we have not faced any issues during simple transactions. We have not extensively tested with new user.

This issue looks like “only the dashboard throwing error message”. But I am not certain if it will cause any impacts elsewhere.

So, just to confirm: if your employee goes to the company list view, they can see the company they are supposed to be able to see?

If so, it’s probably just the chart, which might be hardcoded to show values from the global default company. I don’t have a v13 system to test on, but workspaces have been substantially reworked in v14.