Company transactions deleted but not quite gone

I was experimenting with the software. Once I had things set the way I wanted I deleted the transactions to start fresh. I’ve done this many times before. This time however I had a sub company called :. When I deleted all the records it also removed parts of the sub-company. It would be ok if it removed ALL of the sub company but many records and the chart of accounts remain. I can’t create the sub company again (I assume because the chart of accounts is still there) and I can’t delete all of its records because not enough of the company exists. How do I get rid of these orphaned records?

sorry it removed the company name because I put it in symbols. It was called [company name]:[salesman name]

Hi @Rcomella I think this will answer all your questions:

That is exactly what I did! It did not actually delete everything this time like it did in past uses. It partially deleted some records and left things. That is the entire problem.

@Rcomella it might be a cache issue? did you reload/clear cache?
What branch are you on?

Good thought, unfortunately no. I tried it from another computer and see the same records. I do not understand the branch question. I have it installed on a local Ubuntu server it was the stable version.

Just to fully fill out the story here is what I did. My company does sales for another company. We track their orders but do not actually receive the payments. Each of my salesmen get paid based on their sales. Therefore each of them needs to track their own sales. Therefore I had a main company to track actual income and expenses. After experimenting with the system I found that the sales teams in ERP next did not quite keep enough detail in my case. Therefore I created separate companies that could track the sales cycle for each salesman. Since the master files were shared between all the companies it was great.

I was experimenting with that setup and when I got it set up and ready to go, I cleared the transactions for the main company. To my surprise it also cleared some of the records of the separate companies too. I actually thought that it would leave the other companies alone because I thought they were SEPARATE. As it turns out they are not. When I removed the records from the main company it actually removed much of the “Sub” Companies as well but not everything. Like I said now there are a bunch of records that I can’t totally delete.

The only thing I can think of is that because my companies used similar names the wipe function deleted more than it intended?

@Rcomella the similar name case is not really applicable, but if you created a BRANCH, not a separate company, then this would happen.

As much as I know one site will use one company file, in which once you cleared, you cleared it all.

To clear all transactions do the following:

  1. ssh to your server > go to ~/frappe-bench (if you used the auto install script it will be /home/frappe/frappe-bench .
  2. give command: bench clear-cache && bench migrate && service supervisor restart
  3. if the documents still in there, then go to setup > Accounts > company = your company > Delete Company Transactions.

In this way, all of the docs will be deleted, if not then this would be a bug, might be solved by doing: bench update

Thank you. Following your advice got rid of the sub company’s chart of accounts. Which allowed me to create it again. Once created I was able to access all the orphaned records and cancel then delete them one by one.

I messed up some other things but now the data is good. I will back up then re-install and restore the data. All should be fine then.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.