Copy to Clipboard for doctype, Error: Mandatory field 'name' is missing

Hey everyone,

When I tried to copy the doctype using copy to clipboard, after pasting it into another app, all the detail fields were successfully copied. However, when I tried to change the module and clicked on save, an error occurred stating that the name field is required. The issue is that there is no field displayed for entering the name. How can I solve this problem?


You should think about create an application to allow you to deploy feature between bench.

But with your print screen your Doctype is “New Doctype” and “Not Saved”. That why it doesn’t have a name yet.

I am trying to perform a task across different benches. For example, I want to copy a doctype from the abc app in bench 1 and paste it into the xyz app in bench 2, but it’s not working.

@Manav_Mandli After pasting the Doctype, check the bottom fields tab. The name field is preset here

workaround solution: in browser console run this command
cur_frm.doc.__newname = "doctypename copied"

like this