Could not create server TCP listening socket 127.0.0.1:11000: bind: Address already in use


How to solve the issue?

Hi @THANGAPANDIAN:

Maybe you have other bench instance running?
Try to stop with this command. Be cautious, this will stop any service/application using this TCP ports.

sudo kill -9 $(lsof -t -i:11000)
sudo kill -9 $(lsof -t -i:13000)

Hope this helps.

1 Like


thanks for your reply. still not solved

Check which processes are using this ports with

sudo lsof -i -P -n | grep 11000
sudo lsof -i -P -n | grep 13000


thanks. still not solved brother Thanks for helping me

Hi @THANGAPANDIAN:

Glad to be helpful. You are running other instance using the same ports.

Maybe there is other console open running this. Anyway, tried to reboot the virtual machine?

yes, I rebooted. I use the command sudo reboot. is it any problem? how to solve brother

Hi:

I don’t know about your environment and install method.
Is your site running? Can you access to your site? If other bench is running in this ports, should be reachable on http://yoursite:8000

Try in console

curl localhost:8000

no brother this is my first installation I don’t get access. After I finish the final step (sudo supervisorctl restart all) [Guide] How to install ERPNext v14 on Linux Ubuntu (step-by-step instructions)
Then I want to find my IP address so put the command bench start Unfortunately above errors coming.
thanks for your reply

Hi:

After run sudo bench setup production [frappe-user] you don’t need to run bench start anymore. Your site should starts automatically after system boot.

So bench start try to launch it again, this is the reason for port conflicts.

What do you see with

curl --header "Host: your.site" localhost:8000

?

1 Like

Try this command with --header parameter . Replace your.site with your site name.

curl --header "Host: your.site" localhost:8000


This is what I am getting

Hi @THANGAPANDIAN:

This means that your site is been served. Can’t access from your browser with http://site1.local:8000 ?

This site can’t be reached
The site is not loaded bro. thanks

Hi:

But … you are trying to access from a Windows machine, and your installation is running on Mac …
Is reachable your “linux side” from your “Windows side”? Is the same machine or other one in the network?

  1. Make sure that connectivity is ok.
  2. Add site1.local to your windows hosts file
    a Open your text editor in Administrator mode.
    b In the text editor, open C:\Windows\System32\drivers\etc\hosts.
    c Add the IP Address and hostname.
    Example:
    “yourlinuxsideip” site1.local
    d Save the changes.

Hope this helps.


is correct?

Hi:

Please, detail your scenario. Are you running frappe in a virtual machine hosted in windows?
If you are, in your hosts file:
192.168.1.104 site1.local

And make sure that 192.168.1.104 is reachable from your windows host (ping 192.168.1.104)

In previous post you showed a mac screenshare … so I am a bit confused :wink:
Hope this helps.

yes brother, I am running Frappe within a virtual machine hosted on a Windows environment