Could Not found app "None" when migrate

Dear All,

I am got stucked in an issue after installing authorizenet app. when I try to run bench migrate console says
could not found app “None”
I have checked app.txt but there is no app with None listed there.

Kindly help me.

Thanks and regards.

Can you share full traceback

1 Like

This is a wild guess, since we cant see the traceback (yet), but maybe remove the custom app and then migrate?

1 Like

thanks a lot @saurabh6790 and @trentmu here is full stack.

I was not able to install the app due to following errors:

      1. CommandFailedError: ./env/bin/pip install -q  -e ./apps/authorizenet --no-cache-dir
      2. Command "python egg_info" failed with error code 1 in /home/frappe/frappe- 

then what I did is:

  1. Use bench get-app output was the error 1 above.

  2. then add the app name in sites.apps.txt
    and run the below command

    ./env/bin/pip install authorizenet

this way app get installed but when migrating it shows

        could not found the app "None"

Thank you for quick reply.

OK, you are running the commands as root - this is not advisable. Rather run as user frappe

tried that as well.

Just so I understand… you have logged in as user frappe (or done `su frappe`).
Then removed the custom app
Then done bench migrate
Then tried to reinstall the app?

Can you check the contents of your sites/app.txt? In case this has a line “None”, remove it and try again…

I have same issue after running $ bench setup requirements and my sites/app.txt doesn’t have None and it’s contains all of my apps.

same issue… i think this is a known error in 13.20 update