Creating new app error!

Hi all,

I have a production server and i try to create new app but the following error appear:

/home/frappe/frappe-bench# bench new-app masss new app masss
App Title (default: Masss): sss
App Description: ssss
App Publisher: sss
App Email: sss
App Icon (default ‘octicon octicon-file-directory’): s
App Color (default ‘grey’):
App License (default ‘MIT’):
‘masss’ created at /home/frappe/frappe-bench/apps/masss masss
INFO:bench.utils:./env/bin/pip install -q -e ./apps/masss --no-cache-dir

Command “/home/frappe/frappe-bench/env/bin/python -c “import setuptools, tokenize;file=‘/home/frappe/frappe-bench/apps/masss/’;f=getattr(tokenize, ‘open’, open)(file);‘\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” develop --no-deps” failed with error code 1 in /home/frappe/frappe-bench/apps/masss/
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/bench-repo/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/bench-repo/bench/commands/”, line 40, in new_app
File “/home/frappe/bench-repo/bench/”, line 96, in new_app
install_app(app, bench_path=bench_path)
File “/home/frappe/bench-repo/bench/”, line 107, in install_app
File “/home/frappe/bench-repo/bench/”, line 140, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: ./env/bin/pip install -q -e ./apps/masss --no-cache-dir

how can I solve it plz?

any suggestion plz?

Run this from your frappe bench folder and share your trace.

Thanks for your replying @rmehta

here the trace:

./apps/masss should either be a path to a local project or a VCS url beginning with svn+, git+, hg+, or bzr+

The folder is not created, must be an issue with the permissions on the apps folder. Make sure you have write permission on that folder.

I add all the permissions for apps folder, and my new app folder is created in apps folder.
but the installation does not compete

Don’t forget to do “bench install-app” after!

But the installation of my app did not completed and the error above appeared

Maybe just clean the app and start again.

I tried many times, the same result :frowning:

Same problem here, tried:

sudo su frappe
sudo chown -R frappe:frappe apps/

But not worked :confused:
Any help?