Creation of journal entry automatically in asset depreciation

I have create an asset but the journal entry in the depreciation schedulled was not created .Can you see below snap shot,and let me know if the set up is correct.
1 creating asset category

2 Creating the asset


In company,i have set up these accounts

In Accounts setting

In Asset setting

Just let me know what should i done for the journal entry to create automatically like this one.

1 Like

Refer the below code and make GL entry automatically.

jv = frappe.new_doc(‘Journal Entry’)
jv.voucher_type = ‘Journal Entry’
jv.naming_series = ‘JV-’
jv.posting_date = self.bargain_date = ‘Perceive’
jv.remark = ‘Retained earnings of dividends’
#Entry for Customer
jv.append(‘accounts’, {
‘account’: ‘Debtors - P’,
‘party_type’: ‘Customer’,
‘party’: self.customer,
‘credit_in_account_currency’: rec_dividend_amount,
‘remarks’: ‘Cash devidend credit amount to customer’
#Entry for Supplier
jv.append(‘accounts’, {
‘account’: ‘Cash - P’,
‘party_type’: ‘Company’,
‘party’: ‘Sunil’,
‘debit_in_account_currency’: rec_dividend_amount,
‘remarks’: 'Cash devidend debit amount from Cash account ’

@Solufy iim facing the same Issue as @trishty_thakoor and where does one fix this?

Depreciation entries are posted automatically via scheduled jobs. Check whether Scheduler is disabled in your setup.
You can check it by running bench doctor.
To enable the scheduler, run bench enable-scheduler command from frappe-bench directory.

1 Like


The scheduler is working but still journal entry is not be created automatically in the depreciation scheduler.
Please advise .

Check ‘Error Log’. You may find logs related to Journal Entry. One possible scenario is you have created an ‘Accounting Dimension’ and made it mandatory.

Please have a look

There are no accounting dimensions where it is set up mandatory,

also journal entries should be created automatic? how to enable that?

did u find a solution for this problem @trishty_thakoor

I have the same issue did You find a solution for this problem @trishty_thakoor