Credentials for first login doesn't work on fresh install

I just created a VM with Ubuntu 12.04 and followed the installation setup, using the “Easy Mode” to install all prerequisites and then installed frappe and ERPNext.

Everything worked flawless. Then I started bench using:
bench start

and then pointed to http://localhost:8000 in my browser. Got the login screen, but when I tried to login using Administrator/admin it failed with an “Invalid Login” message.

Any ideas?

Victor Espina

You might have been asked a password on install. Did you try that password?
Else you can try

bench frappe [sitename] --set_admin_password

Thanks, the password I setted during install worked. I now can login and the setup wizard is launched. I entered my personal info, keeping Administrator as user name, entered all initialisation data, but got this error at the end of the process:

I restarted the process and tried to change the username but it won´t allow this neither:

Any ideas of what I am doing wrong ?


Victor Espina

Are you setting your new user as Administrator (in the Wizard?)

Yes, but then the process fails with the first message I posted. Then I tried to use a different user name but it doesn’t allows it (see 2nd message).

I found what I was doing wrong. I first assumed that the wizard was asking to complete the personal info for the Administrator user, but doing that failed with the first error message I posted. After that I assumed that the wizard was asking the info to create another user, so I tried to set a differente username but the wizard didn´t accept any value on that field… until I realized, today, that the wizard was asking for an EMAIL ADDRESS and not an USER ID!! Once I entered a valid email (and one different from the one associated to the Adminstrator user) it worked like a charm!!


Victor Espina

Great - sorry please suggest a way to make it clearer :slight_smile: We have not come across this use case.

Maybe this could work: change input name for User Id and Password on Wizard´s User Profile page, to avoid browser´s autocomplete to assign Administrator name automatically. This was the fact that lead me to think that I was supossed to complete Administrator account info.

I also think on change the invalid user id error message, but I now realized that the text is perfectly clear: it was me not really reading the error message what caused the problem. :smile:

Victor Espina