Currency Rounding to Two Decimal Places

I feel like I’m going a bit crazy here trying to allow my prices to have more than 2 decimal places of accuracy.

In our system settings, the Float Precision is set to 4.
In the Currency, I tried setting the Smallest Currency Fraction Unit to 0.0001, but any time I saved it set back to 0.00
I was able to fix this by setting a custom precision through Customize Form.

I even tried setting a custom precision to the field in Supplier Quotation Item I am changing and it still doesn’t work.

What am I missing?

@Ben_Cornwell_Mott did u try to set field as float and remove Currency from Options?

I’m not quite sure I follow. If you mean did I try changing the field type to Float from Currency, no I didn’t. I don’t really see that as a permanent solution because I’d end up changing every currency field in the system to Float.

There’s got to be a better solution than that…

You should be able to set the currency precision in the System settings.

Hope this helps.

1 Like

Precision can also by set field level, via Customize form

  1. Select the field
  2. Set “Precision” to whatever you want it to be
1 Like