Currency symbol is not showing

Dear team members,
I am using Frappe framework, not ERPNext.

I created 3 currency fields in a custom docType. One currency field is a calculated field.
The rest 2 are input fields.

The issue I am having is the currency fields are not showing the currency symbol, even though the ‘calculated currency field’ is showing the correct symbol. The meta settings for all these 3 fields are same.

I made a comparison with the ‘sales invoice list’ doc type in ERP next. The settings are same as mine.
from ERPNext-

This is how the field behavior looks like in practice-

This is how the setting in ERPNext look like

This is how my settings look like in frappe-

Please help me understanding what am I missing.


ERPNext has a field named “currency” and linked to “Currency” doctype. I think you don’t have a “currency” field.

Thanks Turker for the reply.

I have this field and just like in ERPNext, I also have this linked field and then used this in the ‘options’ for all the 3 currency fields. I have shown this in the screenshot as well.

Interesting thing is only 1 field which is the calculated field is showing the symbol and not others. This is the issue which I am talking about.


I think you don’t have a currency field :slight_smile:
“Currency” field should be in the doc not in the item detail ie child row.

That’s because you are testing it in the single record. Each time try to create a new record and test the behavior in the new record.