Custom app has doctype missing on Desk but shows on Bench

I used bench get-app to install my custom app from Github (which is a fork from Frappe/education in development).

bench get-app

It installs with the warning (that I looked everywhere in the forum and tried a bunch of suggestions to no effect):

WARN: restarting supervisor group ‘frappe:’ failed. Use bench restart to retry.

Yet, when I go to apps/education I see all my doctypes there.
When I go to Desk, I can see many but not all doctypes of this app. For instance, student_applicant exists (with proper contents) in bench cli but is missing in Desk.

PS: I have an account for testing on Frappe Cloud and using their system, the app is installed correctly, with all doctypes.

My localhost shows:

My Frappe Cloud shows:

I would appreciate any advice! I am new to Frappe :wink:


Hi @Murilo_Melo:


bench --site yoursite.local migrate

Hope this helps!

Thanks, @avc

I ran the bench migrate as you suggested, it ran smoothly, no warnings.
However, nothing changed. DocTypes still not showing on Desk.

Any other ideas? Thanks again!

Hi @Murilo_Melo:

Check if this doctype have “Custom” check applied …

If yes … maybe it was created without developer_mode activated, or under other user rather Administrator … In this case, doctype is not stored as .json file , so it isn’t packed into the custom app.

Hope this helps.

Hi @avc
Thanks again for your help.
The doctype was just forked from Frappe Education. On bash I can use nano and see the contents of the json.
My shows a total of 72 doctypes for this app, while my localhost has only 29.
I tried to 1) Change a label in this doctype (VS Code → Git desktop → pushed to Git) 2) Used git pull inside the app on my localhost (success, showed the doctype was updated) → bench migrate
but nothing changed

BTW bench version is 5.22.0
using bench version I see my app, erpnext 15.14.6, frappe 15.15.0

The app may not be installed, try bench install-app education

If you can see the doctype in doctype list then open the doctype (Student Applicant for instance) and on the top right click Go to Student Applicant List. This should take you to the Student Applicant document list. But to fix your issue, you probably need to uninstall and re-install the app from your site as the behaviour is unusual.

Thanks for the help. In the end, I decided to create a new bench and start it from scratch. All working well now. I guess I had a glitch of some sort in the first installation.