Custom app installation "Couldn't find app"?

Hello Everybody
tring to install app from github
first used this command
sudo bench get-app

sudo bench --site site1.local install-app process-manufacturing


Could not find app “process-manufacturing”

Thanks in advance :slight_smile:

1 Like

search Modul-Def List and make a Desk Page

run installing code in the apps folder
cd frappe-bench
cd apps
bench --site site1.local install-app process-manufacturing
its work in this way

What worked for me was:

$ cd frappe-bench
$ echo "appname" >> sites/apps.txt # this adds "appname" into the list of apps
$ bench setup requirements
$ bench install-app appname

I figured this out … The stacktrace pointed to the fact that it was looking for the module in a custom cache. I went ahead and restarted the devcontainers (I am on docker containers for frappe) … and voila… it worked :slight_smile:

I followed ur steps, but still got the error "ModuleNotFoundError: No module named ‘proq_buyer’ ".
I don’t understand what is the error.