Custom App is Unrecognized - Cannot Install

So, using bench get-app, I got an app from a repository, ran the app’s file, and am now trying to install it on a site. However, a prompt says that the app cannot be found.

What could be the matter here?

Help is much appreciated!


To install app run the bench --site your-sitename install-app appname.

Also check your app name is available in the sites/apps.txt file

Thanks, Makarand

…I just said that, upon trying to install it, I see a prompt that says that the app cannot be found. And, yes, the app’s name is in that text file.

Check if your app is inside the /home/frappe/frappe-home/apps/ folder. If not in there you have to run the bench get-app again to download your app to the apps/ folder before you install it.


It’s in ~/frappe-bench/apps/

could you please run the install again and take a screen shot and post.


can it be the name of your apps folder contains an unsupported character or a space? I could imagine that may cause such an error

OK. I ran bench get-app again. This is the traceback after running it:

Cloning into 'vcs'...
remote: Counting objects: 126, done.
remote: Compressing objects: 100% (116/116), done.
remote: Total 126 (delta 47), reused 0 (delta 0)
Receiving objects: 100% (126/126), 42.37 KiB | 0 bytes/s, done.
Resolving deltas: 100% (47/47), done.
Checking connectivity... done.
('installing', u'vcs') vcs
INFO:bench.utils:./env/bin/pip install -q  -e ./apps/vcs --no-cache-dir
Wrote css/frappe-web.css - 65.05 KB
Wrote js/frappe-web.min.js - 137.98 KB
Wrote js/dialog.min.js - 104.41 KB
Wrote css/desk.min.css - 292.1 KB
Wrote css/frappe-rtl.css - 32.37 KB
Wrote js/libs.min.js - 815.22 KB
Wrote js/desk.min.js - 510.75 KB
Wrote js/d3.min.js - 380.17 KB
Wrote css/module.min.css - 2.08 KB
Wrote css/form.min.css - 4.47 KB
Wrote js/form.min.js - 193.27 KB
Wrote css/list.min.css - 14.43 KB
Wrote js/list.min.js - 139.19 KB
Wrote css/report.min.css - 7.89 KB
Wrote js/report.min.js - 257.42 KB
Wrote js/web_form.min.js - 247.22 KB
Wrote css/web_form.css - 24.42 KB
Wrote js/print_format_v3.min.js - 23.39 KB
Wrote css/erpnext.css - 7.87 KB
Wrote js/erpnext-web.min.js - 3.73 KB
Wrote js/erpnext.min.js - 133.17 KB
Wrote js/item-dashboard.min.js - 7.66 KB

So, once again, the folder of the app (vcs) is there, but when I run bench install-app I get:

Could not find app "vcs"

Doubt it; the name is simply vcs.

that looks save (unless there was a minimum of characters required out of any reason. That does not sound too likely to be the case, but who knows)