Custom app missing in Desk sidebar


I have been testing migration for 2 months now. Still missing some knowledge. Hope someone can help.

One of the issues after migration is that Custom Apps is not showing up in the Desk Sidebar. It was created as a Module, and it is shown in Module Def.

Also, under each User page this module shows inside Allow Modules and is ticked.

Under Workspace List, there is a workspace and it is pointing to this module too. Its category is “Module”. Everything seems to be intact.

Except that it doesn’t show up in Desk left sidebar.

I tried re-adding the app to website using:

bench --site < site > install-app <app_name>

with no difference.

Inside /sites directory, inside apps.txt and apps.json, the Custom App is in there.

In web browser, typing: https://site/app/< custom app name> gives:

Page not found popup error.

I just did a git pull from frappe and erpnext version-13, so everything is the latest.

Then I did:

bench setup requirements
bench migrate
bench build
bench clear-cache

All done without errors.

What else can I check?

Hi @charleslcso,

Which version do you use?

Please check whether your workspace is public or not.
If not then edit the workspace and make a public.

Thank You!

Hi @NCP thank you again for your pointer!

There is no where to set Public or Private in Workspace.

bench version shows:

erpnext 13.52.6
frappe 13.58.2

It seems that my User, even with Administrator, is not allowed to access this Workspace. Something is broken… No idea where and how to fix it.

allowed_workspaces: Array is 0

Screenshot 2023-07-26 at 10.07.48 AM

Hi @charleslcso,

Please set the Pin To Top.

Then reload and check it.

Thank You!

@NCP tried “Pin to Top”, same result: it won’t show.

From my dev box, I pin-pointed it down to frappe/desk/’s get_desk_sidebar_items() function.

all_pages = frappe.get_all(“Workspace”,
fields=[“name”, “category”, “icon”, “module”],

and the corresponding SQL is

select name, category, icon, module from tabWorkspace where coalesce(tabWorkspace.restrict_to_domain, ‘’) in (‘Distribution’, ‘Retail’, ‘Education’, ‘Manufacturing’, ‘Services’, ‘’) and tabWorkspace.extends_another_page = 0.0 and coalesce(tabWorkspace.for_user, ‘’) = ‘’ and coalesce(tabWorkspace.module, ‘’) not in (‘’) order by pin_to_top desc, pin_to_bottom asc, name asc;

Running this SQL and the output from my dev box shows the missing “DIY Icons” module (red background):

Doing the same thing in the Production box gives out the exact same output too (green background)!

It seems that the SQL result is normal.

Then it should be that the User has some permission missing.

My side worked property in version-13.

Please check it.

Thank You!

Much much appreciated your reply.

I agree with you; it works on your end, and it works in my Dev box too. I don’t dare to run bench migrate in my Dev box until I figure what the cause of this error.

Just to do some testing, I created 2 new Workspaces:

Individually they are set Pin to Top:

and under my test account I enabled Core and Sogar DIY Icons modules.

Here is the output from the Production Desk:

Hi @NCP ,

After digging further into the data, this User’s allowed_modules does not contain “Sogar DIY Icons”.

There could be something broken inside the User’s Modules.

Something must be broken after the migration…for this User I turned on every module under this User:

But still, the allowed_modules remain the same (shown in the graphic with black background)…

Some else should be broken.

Hi @charleslcso,

I haven’t any idea issue but can you try to restore the database on a fresh site?

@NCP I think the problem is in User permission relating to Modules.

I created a new User, and this user has is given System Manager role, and only some modules. Beside not seeing the Module in the left sidebar, the Home page is not configured correctly too.

Regarding the missing home page, I’m out of my wit.

Do you have any advice?

Please give a Setup module right and then reload and check it.

@NCP great! /app/home is working after selecting Setup! But earlier minor version of version 13 doesn’t have this behaviour.


Now I need to figure out how to get my own apps to display.