Custom Field Linking

Sorry for asking so many questions. Can anyone help me with this?

We use a 2 digit abbreviation for our Supplier Number. For instance, PR or ZA, etc…

I have created custom data field on Supplier doctype. Everything looks fine on Supplier.

Now, I want to use that Supplier Number in other places so I create a LINK field to it. For instance, on Item Supplier doctype. This will allow me to select Supplier Number when setting the default supplier.

When I go to the Item and select the Supplier Number field on the child table, I see the supplier code in drop down with name of supplier (DH in screenshot). But, when I select it, it populates the field with the supplier name. How can I make it to not do this but just show the DH in that field called Supplier Number? It’s doing this every place I use my custom field.

I select it and it displays only the full name but I want just the number/abbreviation we’ve assigned it.

Try to customize the doctype customer. Set the field in which stores DH as title field (not as title field like naming series, i mean as title field like searchable field)…

Addendum: in each case the ‘name’ field is displayed as link. Is your customer id = DH?

Thanks for helping! Really appreciate it. It’s suppliers but same thing as customers. Anyways, I think I’ve already done as you said:

Yes, my supplier id = DH so that’s what I want to show.


if I understand you correctly, then this field is purely informative, you have the link to the supplier already in the left link field “Supplier”.

If your goal is merely that the supplier number is displayed in addition, you can also try the following solution:

In doctype (child table) customization:

  1. change the field “supplier_number” from the type “Link” to the type “Data”
  2. set the property “read only” (–> optionaly)
  3. write the value “supplier.supplier_number” in the field “Options”
1 Like

Yes! This worked. Thank you so much! I didn’t realize that I could put something in options for a data type field. I really appreciate it. :):grinning:

You’re welcome, im happy to help you :wink: