Custom module not showing up for everybody


after creating a custom module for erpnext and adding it to it, it works great.
However the main the reason, why we created the custom module was for it the shortcut to show up in the Desk.

The Icon shows for the Administrator.

I can edit and create doctypes for the Module and open the Module page manually, but I can’t get it to show up for every Employee.

Anybody has gotten also this problem?

Please check role permission user must have permission to one of doc type coming under that module which with you have logged in

1 Like

Users have permission as they can create and view permissions.

I have created also an entry which doesnt change the problem

Are you using latest version ?

Yes, 12.1.8

Turns out the new module doesn’t show for existing users that are employees but for new it shows

Go and check your file in config folder of your custom module.
add your doctype names in that file

Already have added, new users can see the module on the desk, contents:

from __future__ import unicode_literals
from frappe import _
def get_data():
    return [
                    "label": _("Subcontractor Evaluation"),
                    "items": [
                                    "type": "doctype",
                                    "name": "Subcontractor Evaluation",
                                    "description": "Subcontractor Evaluation",

run bench restart and bench build command and check.

Sadly same result, builds fine, but for already existing users that are employees doesn’t show up.
Tried also bench clear-cache

@scdarva you can solved i have the same problem

Surprisingly if the user already existed before the custom module was added this issue may happen. Please follow the following steps given you have created the appropriate files.

Goto Show/hide module
Uncheck the custom module and save
Again goto show/hide module
Check the custom module and save

Hopefully the custom module will show up for the permitted users