Custom Script Not Working in V11

Hello all

Is it me or is are custom scripts not working in V11? Currently on 11.1.6


Hello, I too noticed this disturbing behaviour after modifying a custom doc type and thereafter adding a custom field via the standard customise function.

I duplicated the custom doctype and the script that would not work on the enhanced doctype would work again.

This is quite unsettling

In my case the doctype is a custom one that I created from scratch.

I am hoping some higher minds can help take a look at this

So it looks like the issue is limited to custom doctypes

Try duplicating your custom doctype and test the custom script on the fresh one

Just tried it…No Luck

Would you mind showing a snippet of your code and how you set it up?


I noticed my code doesn’t have the semi colon at the end as does the example

Funny, this is the exam same code am trying to set up

Will remove the semi colon

I am feeling your frustation…it took me some time before I figured out that the problem was the doctype

very very funny indeed!

No Joy

Did not work for me

I’m sorry it didn’t work.

Since you are working of similar content, perhaps duplicate the following doc type (Contract)and add to it as you see fit

From the sounds of things, It has most of the detail you need to get started.

I did that and eventually it worked for me.

What I noticed is that you must not use the customise function but instead, apply all changes directly to the doc type

What version of ERPNext are you on ?