Customer Doctype - naming


i have erpnext 15 installed and have problems in naming “Customer” DocTypes.

On my naming “Document Naming Settings” for the doctype “Customer” i have this “CUST-”, i’ve updated it with the transaction settings update tool. Per default this was “CUST-.YYYY.-”.

I’ve let the customer doctype settings as default on

  • Naming Rule “By Naming Series Field”
  • Auto Name: “naming_series:”

When i add new customer, for example Customer Name: “test” then the customer-id = “test”

I’ve also try to change the naming to random and hash on the customer doctype but the same effect, customername = id

has anyone an idea? before i have the v14 version, there it works.

regards and thanks

Hi @ddggyy,

Please go to the Selling Settings and then set ‘Customer Naming By’.

Thank You!

thank you so much, perfect that’s what i’ve searched for

@NCP i have another question, is there any setting to make this also possible for the addresses?

regards and thanks

No @ddggyy

@NCP is there any possibility to change the naming of the address?

i want it something like the invoice with an incrementor.

regards and thanks

Add custom field like naming series and add your series and try it.

I’ve tried it already, but i only got the default naming. is there anything other what i can do?

Can you still create custom naming series in v15? When I try to do so the field name becomes custom_naming_series instead of naming_series and doesn’t receive an option on Document Naming Settings page.

Hmm :thinking:,

I think it’s possible for the new doctype but not the existing one.

Thank You!

yeah i’ve made the same experience with v15.