Customise form not saving new field


I have created a new field on an existing form but it’s not showing on the form. The form is showing as “Not Saved” but the only button to save is “Update”, it seems as if the new field is being saved but the form is not saving.

Hope that makes sense


Hi, i am facing the same issue, have you found the solution yet?

I am having the same issue. My customized form keeps showing ‘Not Saved’ even after updating the form. Also resetting the form using actions > reset to defaults, did not help.

Some answers from years ago show that this problem is solved in next updates, but I am running the latest versions of frappe framework and erpnext.

Hopefully someone can help solve this error.

I’m having the same issue. Any idea how to fix it?

Hi @Worood_Madwar,

I think, please try to add a field in the custom field form then check. It works or not.
And added field show in custom field or not.

If not work then it’s a bug in system otherwise bench update and migrate it.

Thank You!

1 Like

Thank you for your reply!

I have added it through custom fields and saving it there. But it’s still not appearing in the form for some reason. this is the pic if this helps.

I have cleared cache and rerun the project. And I got a message once that reads ‘core doctypes cannot be customized’ I am not sure what’s the cause.

I am facing the same issue at the moment, but the other way around. I have a custom form of which I would like to remove a field but even a ‘reset to defaults’ does not remove them… I can manually delite the field but it still does not save that.

I have the same issue in version 13 too. I however found another way you can add the field. Add them under the Custom Field doctype and it will automatically reflect in the doctype

use Custom Field list to add

Logging out and logging back in solved this issue for me.