Data import headaches

Yesterday, I was able to do data import (specifically stock reconciliation) without any issues. I don’t know exactly what V12 I was on. I was using the old data import utility.

Our server had a failure last night, and I lost some of the work I did. I have a backup from a few hours before the server problem. I reinstalled ERPNext and loaded the database. In trying to repeat the process of the stock reconciliation I was doing, I’m completely unable to do the data import. It appears the latest version (I grabbed the production virtual machine image) forces the use of the new data import. But it appears broken.

I tried both updating the virtual image (bench update) and not updating it (hoping it would still have the old utility in it as I still have the files I used to do the import and was expecting it to go really quickly). But nothing works.

I get errors, but it doesn’t tell me what they are. I downloaded the template. For updating records, the only thing it requires is an ID. Does it need the company purpose, posting date, posting time? I’m just trying to update the quantity and valuation rates for several hundred items. Any help to figure out what I’m doing wrong or how to use the “new” data import utility would be much appreciated.

While I don’t know why the old Data Import utility is not appearing for you.
If you have files that you used for data import which worked well with the old utility, you can import the data using Bench

Old utility exists as Data Import Legacy DocType.


In case anyone else is wondering, you can find the legacy import by typing “data import legacy list” in the search bar. Maybe there are other ways to find it as well, but that’s the only way I was able to find.