Data Import-The scheduler is inactive

I get this issue when importing data, I have suppliers in.csv format and tried importing but got this pop up: The scheduler is inactive. Cannot import data**
I have enabled the scheduler for my site.
Kindly asking for help.

1 Like

Hi @Kibet_Sang,

can you migrate the site after the enable scheduler?
If not then migrate the site.

Share the command for the information.

bench --site your-sitename.com enable-scheduler
bench --site your-sitename.com clear-cache
bench --site your-sitename.com clear-website-cache
bench --site your-sitename.com migrate

Thank You!

2 Likes

Thank you @NCP for your reply, I did as you have advised and I still cannot import from .csv, check output of commands above.

Migrating kibeterp
Updating DocTypes for frappe : [========================================] 100%
Updating DocTypes for erpnext : [========================================] 100%
Updating DocTypes for hrms : [========================================] 100%
Updating DocTypes for hospitality : [========================================] 100%
Updating DocTypes for ecommerce_integrations: [========================================] 100%
Updating Dashboard for frappe
Updating Dashboard for erpnext
Updating Dashboard for hrms
Updating Dashboard for hospitality
Updating Dashboard for ecommerce_integrations
Updating Dashboard for business_theme_v14
Updating customizations for Address
Updating customizations for Contact
Queued rebuilding of search index for kibeterp

@NCP thanks for support, was able to import, I used the command below

bench --site site_name set-config pause_scheduler 0

8 Likes

this worked for me

1 Like

Yes, it worked for me too

1 Like

Where do I apply this command? fo update settings

Apply that command where it is installed. For those using Frappe Cloud, there is no need to apply the command as it provides this functionality by default.