Data Import Tool - Employee Upload Error

I downloaded the existing employee list from one instance and tried inserting into another instance, without altering any data. Employee list uploading is something basic which does not seem to work. Given below is the trace. I have employee names like EMP/001, EMP/002 …

Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/core/page/data_import_tool/”, line 260, in upload
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 184, in insert
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 322, in set_new_name
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 38, in set_new_name
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 651, in run_method
out = Document.hook(fn)(self, *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 858, in composer
return composed(self, method, *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 841, in runner
add_to_return_value(self, fn(self, *args, **kwargs))
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 645, in
fn = lambda self, *args, **kwargs: getattr(self, method)(*args, **kwargs)
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/hr/doctype/employee/”, line 26, in autoname = make_autoname(self.naming_series + ‘.####’)
TypeError: unsupported operand type(s) for +: ‘NoneType’ and ‘unicode’

Are the naming series for Employee same on both the instances and are both on the same version?

Yes, both are on the same version and have the same naming series.

Tried downloading Employee with data, uploaded the same file on the same instance without any changes, throws up the error.

Can you share the file you trying to upload, let me try on my system.

File sent as requested.

Here is the link to the file on Google Drive as well.

I looked at your file, you are missing naming_series field in your file.

Thanks Kanchan, my bad I did not notice, but it’s kind of strange that the col was missing in the downloaded csv even though I had selected all cols.