Data missing after successful import

Doing a fairly large customer import via the bench tool.

The initial size was around 8000 customers, but I also tried smaller files (<4000).

Most are imported properly, but a few of the items are missing even though they are listed as importing correctly. For example:

cust_import2.log:Inserted row for "Customer: DEMO COUNTY CLERK OF CIRCUIT COURT"Document successfully saved

But the customer is not actually in ERPNext after the import.

Try looking for a pattern with regards to what might have been missed. Lets say you have 4000 records create 10 batches of 400 each and try to upload it. Doing this way you may have a theory on what could be causing data importation to fail. Most likely it might either have to do:

  1. Data formatting issues
  2. Missing mandatory fields

Give the above approach a go we might have more information to debug the issue

Here are few links to posts on related topics that might help

  1. Import Log. Import Failed. Please correct the format of the file and import again
  2. Data Import Error - Please correct the format of the file and import again

You might also want to look and share import logs, that should also help determine the issue

1 Like

Is it possible that the import was successful, but the/this user doesn’t have permissions to view them?

Just as an update, I never got this to work, but I was able to do the import via the API instead and it worked.

Is this behavior something I should file a bug for?

In case someone finds this in the future:

  • importing via the API solved some of the issues I encountered
  • Importing contacts requires a first name. However no errors were thrown about entries missing a first name. Making sure all entries had all of the mandatory fields fixed a lot

My general approach to importing these large datasets into ERPNext is to:

  1. split into multiple files of around 3000 entries
  2. import them via bench import-csv
  3. normalize the input and output csv and run a diff

like which permissions