Import Log. Import Failed. Please correct the format of the file and import again

I am trying to upload a list of around 1400 items. The first 850 are existing records I am trying to update and which I downloaded through the template. The rest of the items are new and I have inserted them below the other records controlling that only correct UOM, Group Item Names and no duplicate Item-Codes are used. For the new items I have left the ID empty. All mandatory fields are populated fully.

If I upload all items the existing ones are updated successfully, but the new ones are not imported.
If I select only “update, don’t insert new” then this also works rest is ignored
If I select “don’t update, only insert new” this creates the error in the Topic Title: Import Log Import Failed Please correct the format of the file and import again.
If I remove the existing records and only upload the rest I get the same error.

Format should not be changed as I only copied the records into the downloaded item template.

Please help.

I think this is the reason of the error, as the ID is a mandatory field. Put in it the item name, like for the existing items. ERPNEXT doesn’t use autoincrement numbers as ID but full text.

Hope this helps.

Also tried this, but same error unfortunately.

Could you create a small import file with a few items which are not confidential and post the file. Also, on which version of ERPNEXT are you?

I am on the hosted version → should be the newest then?

Here is the debug file link:

Thank you for the file @david.rheinbay

The item P-0506 has a barcode that contains an invisible apostrophe (in Excel, it’s a way to force a set of digits to be considered as a text, not as a number). If I edit the cell in Excel then click Enter and save the file, it imports the three items correctly. Therefore, verify that all your barcodes are numbers (if the barcode is aligned to the left, edit the cell with F2 then press Enter, it should transform it back to a number).


Wonderful! Thank you!

also @trentmu says

“Most common problem I have had with imports is a “required” field column of data that is not correctly populated.”

Data Import Error - Please correct the format of the file and import again - #2 by trentmu

Make sure the items are not already in the system by checking from Stock > Items