Database privilege issue while installing new site

Hi @pdvyas @rmehta @revant_one

I have successfully installed frappe bench and am trying to create a new site.
After giving bench new-site command and creating a new site, I am encountering the following error when I open localhost://8000 on the browser.

OperationalError: (1045, “Access denied for user ‘fedb98f755’@‘localhost’ (using password: YES)”)

I am running the frappe-bench on Ubuntu14.04. THere were no errors on terminal end while the command to create the site.

Latest Mariadb seems to use:

I got similar error and I followed steps mentioned in this post:

briefly, as root

killall -9 mysqld

Make sure no mysqld exist. Run mysql with skip grants to be able to login without any password

mysqld_safe --skip-grant-tables &

Login as root

mysql -u root

into mysql prompt

[mysql] use mysql;
[mysql] update user set plugin='' where User='root';
[mysql] flush privileges;
[mysql] \q or exit
/etc/init.d/mysql stop # (or service mysql stop) and 
killall -9 mysqld
service mysql start # (or /etc/init.d/mysql restart)

@revant_one @pdvyas

I just did the above and then tried installing a site. I’m still being asked for a MYSQL root password.

bench new-site library
MySQL root password: super(Connection, self).init(*args, **kwargs2)
_mysql_exceptions.OperationalError: (1045, “Access denied for user ‘root’@‘localhost’ (using password: YES)”)

How do I figure my root password? Or what else could be the issue?

Also I am unable to install any site/app that I download from github cos I’m encountering this same error just as while installing a newly created site too.

mysqlexceptions.OperationalError: (1045, “Access denied for user ‘root’@‘localhost’ (using password: YES)”)

Please help. @revant_one @pdvyas @pdvyas2 @rmehta @ccfiel.

Same thread also has a post to reset mariadb root password


I’m having the same issue :

ERROR 1045 (28000): Access denied for user 'd5ffa11413149b88'@'localhost' (using password: YES)

| Grants for d5ffa11413149b88@localhost                                                                                   |
| GRANT USAGE ON *.* TO 'd5ffa11413149b88'@'localhost' IDENTIFIED BY PASSWORD '*19C7507EFD6EF2089B0D1DCA86E27BF177DADEC0' |
| GRANT ALL PRIVILEGES ON `d5ffa11413149b88`.* TO 'd5ffa11413149b88'@'localhost'                                          |

I doubt the granted privileges the the new user are not taking effect, otherwise how to explain the error is not raised for the user ‘root’.