DateTime field issue


I have added country “South Africa” in Company in Accounts.
But all the DateTime field of Doctypes(custom created) shows Indian Time.
How can it be maked to synchronous with date and time of what country’s that I have set in the setup(Accounts->company)?

Anybody know?

1 Like


Check at Setup => System Settings

Thanks for the Reply…
It’s already done.

So, why the time field doen’t shows the time of that country ??
It shows time of my system!!!


Try setting it up in Setup => User

hello @Nick

This also tried.
Administrator’s timezone is set…
But when I login as Administrator, the datetime field shows system time, not that country’s!

We also have the same problem that the time is set up correctly in the system settings and the user but it shows Indian time. Can someone help?

Likewise here…

I described this issue here: ERPNext Custom DocTypes, Actions, and Links | About Lovia

Datetime field type, in MariaDB, Frappe will create a datetime column, which is without timezone (or hopefully will use UTC timezone). In form web UI, it will be shown as-is, i.e. not converted to local timezone.