Delete Select Error


I was trying to do a bulk delete and it seems there’s an error in the JS. See the Gif below and this was basically happening on all lists, the example below was in the error log, tried it on other lists and they had the same issue.

Thanks & Regards


Seems to work fine on both and, please try to run the bench update command


Actually, I had just done bench update --upgrade from version 7.30 and that’s when the issue occurred

I’m already on the latest versions as well:

Running on ERPNext: on macOS Sierra
Safari Version: 10.1 (12603.
ERPNext: v8.0.9 (master)
Frappe Framework: v8.0.11 (master)

I just tested on Firefox and it seems to be a Safari only Issue, its working fine on Firefox.


I’m not sure how to go about this. Should I start a new thread?

I’m having the same issue on erpnext v10.1.21 frappe v10.1.22. I’ve tried Chrome, Chromium, Firefox all to the same result. I can only delete by entering each record and deleting from there.


The issue is still there, but you can bypass it by checking one item first than you can select the CheckBox to select all the items you want to delete.

Hope this helps

Thanks for the tip @saidsl, though, it doesn’t work. I have no way to bulk delete and I have hundreds of data to delete.

Could this be the problem?

also line 69 for the .delete function. But to me, it seems to be the problem with the code not recognizing that a bulk selection has been made and think that it’s deleting zero selection.


This is how I do it


Any way we can raise this to devs and have it corrected?

mine is a different version to yours, probably why it doesn’t work.

I have the same version, so it should work on yours as well

Apparently, despite bench reporting that the version is 10.x.x, in the web interface, it says develop branch v11.x.x I’ve tried switching to master for both frappe and erpnext, but I think I’ve broken it. It got stuck at u"Column ‘translatable’ cannot be null"

BTW, I’m saying the version is different because on mine, the button on the top right switch from new to ‘Actions’. Yours switch from new to delete.