Desk not showing

I ran into the issue of having used the develop branch of frappe. I had switched the branch to master and did the necessary patching to the database. However, when I start ERPnext, I can see the Login page and other pages. Once I login, an errror “TypeError: get_gravatar() takes exactly 1 argument (0 given)” is shown.

You need to switch the branch for both frappe and erpnext.

I did switch both the branches. I resolved it temporarily by commenting out line 125 and 126 in frappe/ at master · frappe/frappe · GitHub

if not r.image:
r.image = get_gravatar()

Did you update the branches as well? Do bench switch-to-master if you haven’t and then bench update. Maybe one of your branches isn’t in line with the other.

I did the bench switch-to-master as well as bench update --patch. For me, the issue looks like the parameters in get_gravatar method. The get_gravatar method in utils takes an email but none is supplied when called from in master branch.

There’s shouldn’t really be an issue in the master branch, I just tested it. Maybe try git reset upstream/master --hard in the frappe branch?

(That will undo the changes you’ve made as well)

The same error shows up unless I comment out the two lines mentioned earlier.