Development branch: error on customization


Anyone had this issue?

I created some customization and all was going well when, im not sure what i done, but now I get an error when I try to update doctype:

InternalError: (1069, u’Too many keys specified; max 64 keys allowed’)

I also removed all customization and reset to defaults but still getting error if I update.

Looked in forum but solutions proposed did not work.

Any one suggest where i can look as to the reason im getting this error. I have tried to update another doctype and it update with no issue…so somewhere i broke the project doctype.

kind regards

Looks like i found the issue and not sure if this is a bug.

Each time i click on “Update” on customize form i notice that each key is getting duplicated on the database


if I click update again, even if I dont make any changes here is what i get on the database table


All i did is delete the additional keys created and that resolved the error, im hoping that its not going to cause any other issues elsewhere.

Hope this will help other and hope someone can confirm this issue as a bug.

Kind regards


Same for me for Customers Doctype:
ERPNext: v12.x.x-develop () (develop)
Frappe Framework: v12.x.x-develop () (develop)
But I’m not sure to understand what happened.

Bon jour Pierre have you a French environment and perhaps could check on this merci !?

Bad field type French translation for Date “romantic rendezvous”? - #4 by clarkej

@hpema108 I have reported this few months ago here Bench migrate is generating many indexes · Issue #6841 · frappe/frappe · GitHub

But no answer at all!

I am having this issue on v12 branch.

I was able to restore database from v10. But when I tried to migrate Customized doctypes it threw me this error.

Anyone has any idea how to fix it?

I have having the same error please were you able to fix yours?