Development system working, production system does not


I followed the instructions at erpnext-vat-mtd/ at master · software-to-hardware/erpnext-vat-mtd · GitHub

and got erpnext installed. Everything was good till the development system was in place. I was able to log into Administrator and configure the ERPNEXT.

Subsequently when we moved it to the production system (as per instructions provided in the same link), we get the following error


We will be back soon.

Don’t panic. It’s not you, it’s us.
Most likely, our engineers are updating the code, and it should take a minute for the new code to load into memory.

Try refreshing after a minute or two.

How do I enable the Production system?

Check your logs folder inside frappe bench. You’ll find the exact reason there.

In my case this is because bench isn’t running to serve content that nginx isn’t serving directly… It’s looking for upstream content which is not available. If I run “bench start” those daemons will start and it’ll start behaving better … but I’m not convinced this is the correct way for a production config.

I got the same issue just 4 days ago, I disabled production and enabled it again and now it’s working fine.

Don’t know the exact reason but this worked for me:

sudo bench disable-production
sudo bench setup production [user] 

This will overwrite your nginx and supervisor config file.

I made a mistake while creating the site. figured out and then got it working. thanks for all the replies.