Digital Ocean ERPNext install - Cannot restore site data

Ubuntu server 20.04 using Digital ocean guide

Server: Dell R310 Xeon, 16GB Ram, Raid
I am close to being a beginner on both linux and ERPNext.

We have been running ERPNext in VirtualBox on another server, and VirtualBox crashes, not the VM, but sometimes takes down the VM which means it corrupts the database thus requiring a backup VM and a data restore from backup. We want to get this running natively on its own server to hopefully solve this.

So, following the Digital Ocean guide above, I can get a fresh copy of ERPNext install and working on the server. Great!

When I go to ‘bench restore’ our backup data from the VM, none of the passwords allow me to restore to the database. They all fail.

I’ve tried leaving the password blank as in the script, I’ve also tried using a password, but can not bench restore due to password or authorization.

I was able to up load the data after resetting and access to the database using info from here:

But then after, Bench/ ERPNext can’t access the database.

If anyone can explain what might be going on and then ‘spoon feed’ me how to solve this I would appreciate it.