DNS issue Multitenant Setup

Dear Team,

I have setup Multitenant Setup, in all the cloud hosting digitalocean, amaon and GCP too.

its works well .

sometimes site cannot be accessible. gives me such error

i have checked domain is pointing to my IP address. and i have checked in https://dnschecker.org/ its resolves my name to ip

we have tired all the hosting and facing the same issue.

any update !!!

Refer this:

@kartik Thank you…

We are actually facing different issue. We have done Multi-tenant Setup it worked well.

but sometimes sites cannot be accessible. why is it so ?

When it is not accessible is nginx up and running? check with command “service nginx status” if not check what the problem is with it.
The group of processes is managed by supervisor.

Yes nginx service is enabled and up and running.

Maybe checking this might help.


Check fail2ban settings. If site is not available for few minutes then due to constant connection fail2ban is blocking the IP. Let’s say after 10 minutes it clears the IP hence you are able to connect. Maybe using VPN on Epic browser would help.

Has anyone been able to set up DNS Multitenancy on DigitalOcean? I’ve been trying for several hours any even though running the multitenant config command does not show any errors only the default site shows up. Even when I enter the url for the new sites, it still reverts to the default site.

Is supervisor installed and correctly functioning?


  1. All your subdomain should point to server IP address
    example: xya.erp.com → nnn.erp.com →
  2. ERPNext should be in production mode
    Setup Production
  3. Follow DNS based multitenancy steps
    Multitenant Setup · frappe/bench Wiki · GitHub
    Note: For “DNS based multitenancy”, currentsite.txt in frappe-bench/sites/ should be empty.

Please ensure all above steps are done and share details of error/issue

1 Like

Thanks for the reply. I eventually figured out what the issue was. Apparently Nginx wasn’t setting up to recognise the new site configuration. So I ran bench update --patch and set up and reloaded nginx and everything is now fine. I don’t know why nginx failed to initialise the first time.

Hello dineshpanchal432 did you manage to sort this issue?
Facing the same,

all set but in the end the dns not being resolved