[Docker] Bench response delayed on Mac

Hey! I’ve had some trouble turning a MacBook manually into a Frappe/ERPNext-Development-Machine. So I’ve tried the Docker approach, which is working quite well so far. But there’s a little inconvenience. A delay of at least 2 seconds after a bench command was entered.

I’ve installed Docker Desktop via Homebrew (brew cask install docker) and followed frappe_docker/README.md at main · frappe/frappe_docker · GitHub

Any idea? Anyone? There is no delay with the same setup on a Linux machine.


I’ve not tried it on Mac or windows personally. I use it on linux.

Davide uses Mac I guess.

It is recommended you allocate at least 4GB of RAM to docker

Is it because of this?

@revant_one Thanks for your reply.

I don’t think it has anything to do with the amount of the allocated RAM. I’ve had 4 GB allocated to Docker and everything else is working as aspected speedwise. I believe it’s kind of a Mac specific problem. Unfortunately, I haven’t had the time to dig deeper into it.

Related Post: