Docker compose failed

I’m getting an ‘ERROR: no such image: frappe/erpnext-worker:: invalid reference format’ when running docker docker-compose --project-name <project-name> ...
Previously it was ‘ERROR: no such image: frappe/frappe-socketio:: invalid reference format’ .

I’m following official installation documentation at here

This is not docker based install

did you copy any env file into .env

env file has tag versions mentioned for images

Hi @revant_one

Trust you’re doing great. I just encountered the same error! …yes, I copied the env-example file to .env and set all the variables yet I get warnings that they’re not set! What could be the problem?

Kind regards,

It has to do with version of docker-compose.

In some version it needs .env file in the same directory where yml is.

In some version it needs the .env file where you exec the command.

Try changing place of .env file

Hi @revant_one

Copying the .env file to the ‘Installation’ folder worked but there’s another error when trying to create the first site. Please see below:

docker: Error response from daemon: network erp-net_default not found.
ERRO[0000] error waiting for container: context canceled

erp-net is the name of the project. Any idea what the issue could be?



Try cleaning containers and volumes with a fresh start.

I’ve no idea. I’ve not faced this issue yet.

Okay, will try that now…

Hi @revant_one

Still the same :pensive:

Also tried using the commands described at GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps

It returns the error below:

Unable to find image 'erp-net_erpnext-python_1:latest' locally
docker: Error response from daemon: pull access denied for erp-net_erpnext-python_1, repository does not exist or may require 'docker login': denied: requested access to the resource is denied.

Any suggestions what else I can try?

So I inspected the Docker network and realized all the containers were on the ‘webproxy’ network which was created by the letsencrypt nginx proxy setup. I then replaced --network <project-name>_default \ in the Docker new site commands with --network webproxy \ and it worked

You may want to take a look at this so it doesn’t cause some confusion for users

Thanks for the awesome job and the tireless support (even though it’s volunteer work!!!)

1 Like