Docker Installation

So I’ve tried to install erpnext using docker and the installation was successful. But after installation, I tried docker ps on the terminal and this is what I’m getting.

CONTAINER ID   IMAGE                         COMMAND                  CREATED       STATUS                          PORTS                                      NAMES
4d7253a87e7a   frappe/erpnext-worker:edge    "docker-entrypoint.s…"   3 hours ago   Restarting (1) 36 seconds ago                                              frappe_docker_erpnext-worker-long_1
a891b24624b2   frappe/erpnext-worker:edge    "docker-entrypoint.s…"   3 hours ago   Restarting (1) 46 seconds ago                                              frappe_docker_erpnext-schedule_1
724a29350478   frappe/erpnext-worker:edge    "docker-entrypoint.s…"   3 hours ago   Restarting (1) 40 seconds ago                                              frappe_docker_erpnext-worker-short_1
4602ddec2400   frappe/erpnext-worker:edge    "docker-entrypoint.s…"   3 hours ago   Restarting (1) 1 second ago                                                frappe_docker_erpnext-worker-default_1
ee2c035d6f6c   frappe/frappe-socketio:edge   "docker-entrypoint.s…"   3 hours ago   Restarting (1) 4 seconds ago                                               frappe_docker_frappe-socketio_1
5bb575ceb1ab   frappe/erpnext-nginx:edge     "/docker-entrypoint.…"   3 hours ago   Restarting (1) 17 seconds ago                                              frappe_docker_erpnext-nginx_1
e76805def8da   redis:latest                  "docker-entrypoint.s…"   3 hours ago   Up 3 hours                      6379/tcp                                   frappe_docker_redis-cache_1
cab5a593883a   redis:latest                  "docker-entrypoint.s…"   3 hours ago   Up 3 hours                      6379/tcp                                   frappe_docker_redis-socketio_1
03acf71f3cc7   redis:latest                  "docker-entrypoint.s…"   3 hours ago   Up 3 hours                      6379/tcp                                   frappe_docker_redis-queue_1
6933189f7e79   frappe/erpnext-worker:edge    "docker-entrypoint.s…"   3 hours ago   Restarting (1) 8 seconds ago                                               frappe_docker_erpnext-python_1
bb4c4ea08513   traefik:v2.2                  "/ --lo…"   3 hours ago   Up 3 hours            >80/tcp,>443/tcp   frappe_docker_traefik_1
628d99b07b3f   mariadb:10.3                  "docker-entrypoint.s…"   3 hours ago   Up 3 hours                      3306/tcp                                   frappe_docker_mariadb_1

Has anybody else faced this issue while installation? WHat’s the workaround to this? I’m using a 64bit Ubuntu Server 21.04

Don’t use edge images in production.

what are the logs of the failing containers?

here’s what I got in the logs

standard_init_linux.go:219: exec user process caused: exec format error

Sorry I can’t help.

Can you share your docker-compose file if someone else can find anything?

Sharing my quick and dirty docker-swarm deployment method, with stacks (sparse at the moment, I am sanitising stacks and uploading them as I find time) including all in one single site ERPNext.

1 Like

Create a post for it if you wish. You can add custom recipes to frappe_docker/wiki, add link to your repo in the wiki.

  1. Three redis can be reduced to 1, use redis:6379/0, redis:6379/1 and redis:6379/2
  2. If you are using traefik and all the public containers are connected to traefik-public network then each stack for erpnext that is added should name its services with unique names. e.g. erpnext-nginx becomes erpnext-nginx-staging, erpnext-nginx-prod, erpnext-nginx-00
1 Like


Tested and appears to function properly, so have updated to include only one redis. I was basing this off of the provided docker swarm example.

Traefik services are already based off of a variable set in portainer, typically the stack name. The header describes required stack variables.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.