Docker maria db error

Am new to docker, i have followed the procedure but am getting this errors. I have followed different discussions but i can’t figure out where am going wrong

(1045, u"Access denied for user ‘1bd3e0294da19198’@‘frappe.frappedocker_default’ (using password: YES)")![39 AM|690x431]

frappe-bench/sites/site1.local/site_config.json contains

“db_name”: “1bd3e0294da19198”,
“db_password”: “cwe3NSCiLR7lTdEd”

docker-compose.yml contains

version: ‘2’
image: “mariadb”
- ./conf/mariadb-conf.d:/etc/mysql/conf.d
- “3307:3306” #mariadb-port
container_name: mariadb

1 Like
  • Up vote

Same error on my end. Tried a lot workarounds and fixes.

Things that i tried are

  1. Removing all volumes, network drives and bind volumes, so i can start from fresh
  2. Trying to manually allow a user (which i am guessing is one of the erpnext workers) GRANT ALL ON . TO ‘_c56bfbb8e06ec5a8’@‘’ IDENTIFIED BY ‘admin’
  3. Adding MYSQL_ROOT_HOST=% to .env and even downgrading maraidb to 10.1 based on some post.

This issue is getting really frustrating to resolve. Any pointers to look anywhere else is really appreciated.

Some insight on the error
2021-11-01 6:50:47 162 [Warning] Access denied for user ‘_c56bfbb8e06ec5a8’@‘’ (using password: YES)
2021-11-01 6:51:47 163 [Warning] Access denied for user ‘_c56bfbb8e06ec5a8’@‘’ (using password: YES)
2021-11-01 6:52:36 165 [Warning] Access denied for user ‘_c56bfbb8e06ec5a8’@‘’ (using password: YES)

Using the env-local as the environment and the default docker-compose.yml file in the repo.


For god’s sake, have you found any solution for this? I have exactly the same issue with no clue how to solve it.