Doctype Link Lost After Recent Update

Hi All! I am new here and is starting a project using ERPNext. I notice a prompt yesterday about an update and notice a change.

Supposedly, if I will open an Item for updating the upper left corner of my screen will show like this : E > Stock > Item . Those are links from Home, Stock Module and Item Doctype in List View respectively. But earlier today, I only notice this instead :

The Upper Left Corner only shows E>Stocks. I can’t remember editing something aside from Custom fields and Customize Forms.

Any help is greatly appreciated. Thanks!

1 Like

Hi, @creamdory. Welcome to the forum.
Assume you’re on SaaS subscription and you’ve received update to Frappe 7.0.21 / ERPNext 7.0.27, correct me if I’m wrong.
I’ve received the same update on SaaS subscription and can’t replicate your issue. Have you tried cleaning the cache in a browser?

Hi @strixaluco! Thanks for your prompt response. I really appreciate it. I tried your suggestion but currently no luck.

Please confirm your type of hosting and software versions.
Quite frankly, I don’t see any issue in behavior, that you are allegedly facing now. Would you consider making illustration of your expected behavior? Just edit the screenshot in a way, that you expect it to look.

@creamdory Welcome to the community!. I Think this is a bug. I have replicated your problem. @rmehta has committed this code yesterday

This cause the problem. I tried to revert this 2 files. Now breadcrumbs is ok.

@creamdory Please create an issue in github :slight_smile: Good catch!

Hi @strixaluco I was referring to the breadcrumb on the the upper left corner of the window. It is suppose to be like this: (Photo screenshot taken way ahead)

I am not subscribe to an hosting since I set-up my own server. Thanks!

Hi @ccfiel thanks for the warm welcome! I see that this is a bug. I will create an issue on github. Thanks!

This is what I have on SaaS, Frappe 7.0.21 / ERPNext 7.0.27:

@strixaluco SaaS is usually delay in updates. The update in code made by @rmehta was just yesterday.

Indeed. It may take up to week for changes in develop branch being released to SaaS instances.

1 Like

@rmehta Thanks for the fix!

3 posts were merged into an existing topic: Where is Payment Tool in V7

In V7, if I go to the detailed object i.e. one purchase invoice, the breadcrumbs is not updated to give me the navigation to the list level. I checked V6 and it is working fine.


Hi @guojian83! I had the same issue posted earlier. It was a bug due to an update but already solved. Please refer to my previous thread. Thanks!


That is excellent. I pulled the latest version and it works now.
Thank you @creamdory .


Hi @guojian83! Glad to be of help.