Document Naming Series

Hello There,

I am very new to ERPNEXT and I am not a conding/software person. I am using Locally Hosted ERPNEXT14 for my small business since last 3 months and it was working very fine for me. Today I updated the bench using $bench update command and everything went fine.

While I was creating a New Purchase order after this update, The document naming series is no more respecting the format which I have set. My Purchase order series is PO.FY.### so the new purchase order number should be PO2023-24005 but upon saving the Purchase Order it gets a number PO001. I tried to delete the draft PO and recreate it and I got the same result.

Then I once again updated the bench by running the command $bench update --rest and rebooted the complete system but with no luck.

can anyone please help me in setting up the document naming series to the one I had before the update?

How did you configure it?

You should use to configure

I followed the guidelines referred by you. I created 02 Purchase orders today. first one was working fine with given naming series. then i updated the bench and created the second Purchase order and the naming series is no more working. I am running ERPNEXT14 on a virutal machine at my local network.


here are the screen shots of both the Purchase Order Numbers for your easy reference. I don’t know what went wrong? :frowning:

Hello @ankush

While I tried to update the bench again, I got this error:

ModuleNotFoundError: No module named ‘bench.patches.v3’

can you please help me?