Doesnot show general ledger and stock ledger

i am using erpnext v7 on ubuntu 14.04 LTS, and all things were going smoothly but starting from yesterday, the system stops showing general ledger report on finance and stock ledger report on stock?what can i do please?also when i make a jouranel entry and wants to check the ledger it doesnot show?it was working till Saturday?what shall i do please?thanks in advance.

Hi @Sachine_P1,

Did you getting any error while accessing the reports? Any error on console log?

Thanks, Rohit

@rohit_w it doesnot show any error just simply doesnt preview any thing even the headers like date acoount and all things are not coming?i have also restarted my server but its the same.

@rohit_w sorry where can i check the console log?

Hi @Sachine_P1

check link web development - How do I open the JavaScript console in different browsers? - Webmasters Stack Exchange


dear @rohit_w i have checked it but it doesnt show any error, ihave tried it using 3 browsers chrome, mozilla, opera but its the same for all before 2 days it was working well, does the size of data have problem as on the last 2 days we have posted so many datas?thanks

Hi @Sachine_P1,

Did you import any old database?
Run bench migrate command in frappe-bench folder and check


@rohit_w i didnt import any thing, i have checked it before 2 days but stops yesterday,also when i post sales invoice or purchase invoice and wants to check the accounting ledger its not showing.also after postiong journal entry when i click ledger its not showing but on my custom report its showing shall run the command as you said?thanks.

Hi @Sachine_P1

Run bench migrate command in frappe-bench folder and check.

I have been trying to get both of reports and I can’t get them. I tried in local installation (v 8.0.8) and on, but it doesn’t show them.

Thanks in advanced

I made another test on When I try to access to General Ledger report, in the browser console is showed this error:

Uncaught RangeError: Maximum call stack size exceeded
    at RegExp.exec (<anonymous>)
    at RegExp.[Symbol.match] (<anonymous>)
    at String.match (native)
    at jb (
    at db (
    at eb (
    at pb (
    at ob (
    at nb (
    at qb (
    at rb (

Uncaught SyntaxError: Invalid regular expression: /(^|>|\s|\.|-|/|\\|,|\$|\!|\?|:|;)(aa)($|<|\s|\.|-|/|\\|,|\$|\!|\?|:|;)/: Stack overflow
    at RegExp.exec (<anonymous>)
    at RegExp.[Symbol.match] (<anonymous>)
    at String.match (native)
    at m.formatDate (
    at (native)
    at m._setInputValue (
    at m.selectDate (
    at Class.set_input (
    at Class.prototype.(anonymous function) [as set_input] (


Just merged a fix.
Please confirm if the issue is fixed for you.

Hi @netchampfaris

I tested it on again. The fix solved the error.

Now it works like a charm. :slight_smile:


@Sachine_P1 Have you ever got this to work? I’m having the same issue with the General Ledger but not the Stock Ledger.