Domains, Workspaces, Modules...oh my

Hi all,
I am a newb, so apologize in advance. I recently installed v13 and am having a hard time getting a new module or domain listed on the sidebar. I feel like I have tried just about everything, but surely am missing something. I defined a new app with bench, created a new domain workspace and new module workspace. I then tried clearing cache and migrating with bench, rebooting and even poked around in the db to manually add an entry. Nothing. I am using the Administrator account and have my new domain module selected in settings as an active domain. I was goofing around yesterday on a test install in the file and did get a new module to show up on the sidebar, but can’t seem to make that happen in my current environment. Is there a utility I should run or best practice to follow to have a new workspace/page/module display in the sidebar? Thanks in advance!

1 Like

add at least 1 doctype to the workspace and try refreshing

No, still an issue…
Ok, so I have the following in place:

  • developer mode is enabled
  • a new app called ‘knowyourgrow’
  • a new domain called ‘Cultivation’
  • a new module called ‘Cultivation’ that uses the ‘knowyourgrow’ app and is restricted to the ‘Cultivation’ domain (I tried both ways)
  • a new workspace called ‘Cultivation’ that is categorized as a Domain
  • a new doc type called ‘Strain’ that uses the ‘Cultivation’ module
  • a new role called ‘Cultivator’ that is restricted to the ‘Cultivation’ domain
  • the Administrator has the ‘Cultivator’ selected
  • the core Domain settings have the ‘Cultivation’ domain set active

I am logged in as Administrator and have tried running bench migrate, clear cache…what else am I missing?

Silly question perhaps, but in your workspace have you added “Strain” to either a link card or a shortcut?

There are no silly questions! At least when you are talking to me…you nailed it! I added a shortcut and both the module and domain showed up in the sidebar :vulcan_salute:

1 Like