Easiest & Simple Way to Install ERPNext 13

I am installing it on a new VM on my local PC Ubuntu 20.

I have removed the user tag and still the same error.
should I try uninstalling python 3.8 and use with python 3.7 ?

Hi All,

I managed to install ERPnext 13 on a Oracle arm64 server (that too in a LXC container) without much hassle. I will try to make a full guide in the coming weeks, but if someone wants to try now than please do this:

I followed the steps highlighted here: How to deploy ERPNext 13 on Ubuntu 20.04 LTS (Focal Fossa) | Scaleway Documentation and just changed amd64 to arm64 for the instructions to install wkhtmltopdf.

There was a few errors, but the markupsafe error was resolved by sudo pip uninstall MarkupSafe and then installing other version sudo pip install markupsafe==2.0.1 (source: Error while creating new-site - ERPNext - ERPNext Forum)

I haven’t checked the installation yet, but so far seems ok. Hope this helps.

1 Like

I haven’t checked the script yet since I spent hell lot of time doing the implementation on WSL and what now.

But for this script, for me, it was able to launch ‘bench init …’ command. I read through the ansible logs and found out “frappe-bench” wasn’t installed. Simply installed it via pip and it got through

Edit: ‘bench’ commands are not working through ansible playbook, after bench init, bench get-app failed too.

P.S: Not an issue, can be solved by manually executing failed commands

Hi everyone, as I mentioned I will be sharing step by step installation guide for ERPNext. Using these steps I have done more than 30 installations without error. So I have provided the step-by-step guide in this article.

3 Likes

I followed carefully your steps:

  • Step 11 needs to be run with sudo maybe you want to update the command.
  • The script fails after setting both passwords.

Traceback (most recent call last):
File “install.py”, line 497, in
install_bench(args)
File “install.py”, line 278, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 413, in run_playbook
success = subprocess.check_call(args, cwd=playbooks_folder, stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.8/subprocess.py”, line 364, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=my_user’]’ returned non-zero exit status 2.

Any ideas why?